Q100301: "An unexpected error occurred" when trying to install a license

SYMPTOMS

When installing or activating your license on a machine, you may encounter the following errors:

An unexpected error occurred

1.png


 

CAUSE

There is a known issue with licensing where our programs are unable to write a license file or create the directory if the file path contains non-ASCII characters. This can happen if your username contains special characters such as an accented letter (e.g. ë) or an @ symbol.

 

This error can also occur if the system date and time of your machine is set in the future or you have future modified dated files on your machine.  Further information on this issue can found in this guide:  Q100217: How to resolve the "Clock setback detected" error message

 

RESOLUTION

You can workaround this issue in a number of ways:

All license types:

Changing the username to remove the non-ASCII character(s) should resolve the issue for all license types.

Login licenses:

When on a Windows machine it is possible to enable UTF-8 which should allow you to access your license with non-ASCII character(s) in your username. Enabling this setting can be done by following the steps below:

  1. Open the Settings Panel

  2.  Select the Time & Language option

  3.  Select the Region option on the left-hand side

  4. Click Additional date, time, & regional settings under the heading Related settings in the top right of the window 

  5. Click on Region

  6.  Select the Administrative tab

  7.  Click Change system locale...

  8.  Tick on Beta: Use Unicode UTF-8 for worldwide language support and click OK. If you are asked to restart please restart Windows to complete the change.

Nodelocked licenses:

When installing a Nodelocked license using the FLU 8.1.6, it will write the license to your user area. You can use FLU 8.1.3 to install the license to your system location instead in order to avoid this issue.

The FLU 8.1.3 can be downloaded via the following link:

Mac download

Linux (.deb) download

Linux (.rpm) download

Windows download

Once FLU 8.1.3 has been installed please follow the steps in the following article to install the license: Q100026: How to install a Nodelocked license 

 

The FLU 8.1.3 installs licenses to the path below. Manually dragging the .lic file to this location should also fix the issue:

Windows: C:\ProgramData\The Foundry\RLM\ and C:\Program Files\The Foundry\RLM\

macOS: /Library/Application Support/TheFoundry/RLM/

Linux: /usr/local/foundry/RLM/


FURTHER READING

More information about licensing is available in the following articles:

    We're sorry to hear that

    Please tell us why