SYMPTOMS
After setting up your Floating license server and pointing your computer at the license server, the program fails to run and shows one of the following error messages:
Communications error with license server (-17)
Connection refused at server (-111)
or
Communications error with license server (-17)
Read error from network (-105)
CAUSE
This error message will appear if the server isn't running or there is a firewall between the license server and the client machine (the computer requesting the license).
The firewall may be blocking the license request by either closing the ports that the license request uses or by only letting approved programs on the server communicate with other computers.
We have also seen this error when customers network security recognizes RLM traffic as suspicious and blocks this communication.
RESOLUTION
You can fix this issue by changing your firewall settings to allow the license server and license requests to pass through it. This can either be done by opening the specified ports for the server or by allowing the RLM server program within the Foundry Licensing Tools (FLT) to communicate through the server.
Please see Q100216: How to use a license server through a firewall for more information about how to set this up.
If your network is very locked down then we would suggest setting a port for the ISV to run on then allow this through the firewall as well. More information on how to do this can be found in the article here: Q100374: How to make the RLM server use a dedicated ISV port
FURTHER HELP
If you are still experiencing difficulties please create a support ticket to let us know the exact issue encountered and the troubleshooting steps that have been taken. Please attach any diagnostic output files from the Foundry License Utility (FLU) for both the server and client machines.
For more information on how to open a support request, please refer to this article: Q100064: How to raise a support ticket
For more information on how to generate a license diagnostic log, please refer to this article: Q100105: How to generate a license diagnostic log via the FLU for troubleshooting license issues
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