SYMPTOMS
The RLM server begins to run slow or crashes when trying to float your licenses.
CAUSE
This can occur when there is a large back-log of old licenses or logs installed on the server. It can also happen if you have a large number of users accessing the server at a time.
RESOLUTION
Removing old licenses or logs
In order to resolve this issue please remove any old expired licenses and any large log files from the server machine via these steps:
-
First of all please ensure that you are running the latest build of the FLU available here.
Note: If you are running on macOS/Linux, you may experience issues installing the server via FLU 8.1.6, please run 8.1.3 instead. This is available to download here:
Mac FLU 8.1.3
Linux FLU 8.1.3
- Stop the server by opening the FLU, navigating to ‘License Server’ then selecting ‘Stop server’
- Remove any old license files from the following paths:
Windows: C:\Program Files\The Foundry\RLM and C:\ProgramData\The Foundry\RLM
MAC: /Library/Application Support/TheFoundry/RLM
Linux: /usr/local/foundry/RLM
- Remove any .log files from this path:
\TheFoundry\RLM\log
-
Re-install the latest valid licenses.
Please contact sales@foundry.com if you would like your most recent licenses re-sent.
Server lag caused by a large number of users
If you have a very large number of licenses this can be taxing for your server and cause lag. In order to avoid this you can temporarily transfer a set of licenses from your main server to another machine on your network so they can be floated from there.
More information on this can be found here: Q100221: How to float some of your RLM licenses from another server on your network
FURTHER HELP
If you are still experiencing difficulties please create a support ticket to let us know the exact issue encountered and the troubleshooting steps that have been taken.
For more information on how to open a support request, please refer to this article: Q100064: How to raise a support ticket
FURTHER READING
More information about Floating licenses can be found in the articles below:
Q100602: Where to find more information about Floating licenses
Q100221: How to float some of your RLM licenses from another server on your network
Q100532: How to manage your license server using the Foundry Licensing Utility (FLU)
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