SYMPTOMS
Our Floating licenses are set to be shared on a one-per-host-machine basis. This means a user can run multiple instances of a program on their workstation while only taking one license from the server.
However, in some circumstances it is possible to end up with multiple Floating licenses checked out to a single user/host machine but the good news is that this can be prevented.
CAUSE
RLM servers group licenses together by feature name and version number (maintenance date). If you have multiple licenses for the same product with the same maintenance date then they will be floated from the server in one large pool.
The maintenance date of a license can be identified by the date next to the product name in the license text. For example the following license:
LICENSE foundry nuke_i 2022.0622 is a Nuke interactive license with a maintenance date of the 22nd June 2022.
In practice this means that multiple licenses for a product with the same maintenance date will all be floated in the same pool.
Installed licenses with same maintenance date
Resulting license pool
However, if you have any licenses with a different maintenance date (and therefore different version number) then the server will float them from a separate pool.
This shouldn't cause any problems but we've discovered an issue with RLM licensing that can lead to multiple licenses checked out to a single user, but from our testing this ONLY happens if the version in the second pool is lower than the version in pool 1.
License Installation
Resulting License pool
In theory this could happen if a user has additional licenses with a lower maintenance date than their permanent licenses.
RESOLUTION
We can avoid this by ensuring that where possible short term licenses are generated with a matching maintenance date as existing licenses.
If you already have licenses with different maintenance dates, then you can prevent duplicate checkouts by manually editing the license file on the server to arrange the licenses in order of maintenance date so the higher versions appear later in the file.
Need additional help?
If you are still experiencing difficulties please create a support ticket to let us know the exact issue encountered and the troubleshooting steps that have been taken.
For more information on how to open a support request, please refer to this article: Q100064: How to raise a support ticket
FURTHER READING
Q100602: Where to find more information about Floating licenses
Q100264: How to point a machine to your license server
Q100211: How to check which licenses are available from an RLM server
Q100523: Where are Foundry licenses installed on my machine?
Q100106: How does Nuke licensing work?
We're sorry to hear that
Please tell us why