SYMPTOMS
After performing a Texture Transfer by selecting Channels > Transfer, users may find that Paint nodes in the new Object are empty, as if the transfer didn’t work. Meanwhile, other nodes with image data, such as Cloud and Tiled, transferred successfully.
However, if the user moves the camera really close to the asset, the missing paint data appears, and it disappears again when the user zooms back out. In the following example of a completed Texture Transfer, the Cloud node used as a texture and the Checkerboard node used as a mask are visible, but the transparent areas that should be covered by Paint nodes remain transparent. As the user zooms in, the Paint data reappears:
CAUSE
This issue is caused by the following known bug:
Mari, like other 3D packages and videogames, uses Mipmaps to improve performance and reduce aliasing artifacts. The lower resolution mipmaps, which would be used when the asset is seen from a distance, don’t get created due to this bug. Only the highest resolution images are available, which is why they appear when they should - when the user zooms into the Object.
RESOLUTION
In any instance where Mipmaps are missing, we can trigger any process in Mari which recreates them in the affected Paint nodes. There are a few ways of doing this, and from the following examples, the first two allow you to restore the original node tree.
Method 1: Select one affected Paint node and right-click > Edit > Bake to Paint Node.
NOTE: Method 1 will need to be repeated for each individual Paint node.
Method 2: In the UV View, increase the Radius of your brush so that it covers every UV, then paint every UV of every Paint node white in Multiply painting mode.
Method 3: Add a Bake Point node before the Channel node and bake it.
Method 4: Export the Texture Transferred Channel using the Export Manager and then reimport the textures into a Paint node.
FURTHER HELP
If you are experiencing difficulties please create a support ticket and provide us with the information requested in this article:
Q100090: Information to send Support when reporting a Mari issue
For more information on how to open a Support ticket, please refer to this article:
Q100064: How to raise a support ticket
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