Q100684: Nuke failing to launch with "OpenCL Error: CL_INVALID_DEVICE" or "Unsupported OpenCL device" error on Windows 11

SYMPTOMS

Some users are currently unable to launch Nuke, and are receiving the following error:

EXCEPTION REPORT
 User message is 'OpenCL Error: CL_INVALID_DEVICE (Device invalid or not associated with context)'.
 Threw exception of type RIP::Compute::OpenCL::DeviceException
  From Compute::Compute::OpenCL::OpenCLDevice.cpp:231 in 'RIP::Compute::OpenCL::Device::createDeviceInfo'
 Decoration is...
   [Error] = CL_INVALID_DEVICE (Device invalid or not associated with context)
    UserMessage] = OpenCL Error: %%(Error)%% [UserMessage] = OpenCL Error: %%(Error)%%

Or:

EXCEPTION REPORT
User message is 'Unsupported OpenCL device'
Threw exception of type Foundry::Base::Exception
From W:.conan\7c7cb3\1\Compute\src\OpenCL\ripOpenCLDevice.cpp:217 in 'RIP::Compute::OpenCL::Device::createDeviceInfo'
Decoration is...
[CLDeviceType] = 5
[UserMessage] = Unsupported OpenCL device

The issue appears to happen in all tested Nuke versions between Nuke 10.0v1 and 15.0v2, but only seems to affect users on Windows 11.

 

CAUSE

We believe this is related to a Windows 11 update or a GPU driver update, however we have not been able to confirm it this is the exact cause and, if so, which update could be causing this issue.

We have been able to reproduce the issue in house by installing the OpenCL™, OpenGL®, and Vulkan® Compatibility Pack onto Windows 11 machines. As such we have logged a bug for this issue, which you can check the report for by using the link below:

ID 564372 - Nuke crashes on launch due to OpenCL Error

 

RESOLUTION

As of Nuke 14.1v4 and 15.0v4, the following bug has been addressed and the issue should no longer occur:

ID 564372 - Nuke crashes on launch due to OpenCL Error

Download links for these Nuke releases can be found on the following page of our website:

Download Nuke

For Nuke releases prior to Nuke 14.1v4 and Nuke 15.0v4, having the OpenCL™, OpenGL®, and Vulkan® Compatibility Pack installed from the Microsoft Store here can cause this issue, please can you check if you have this installed, and if you do, please uninstall it. You can do this by searching for Add or Remove Programs in the Start menu, then in the Apps list search for OpenCL™, OpenGL®, and Vulkan® Compatibility Pack and uninstall it:

NOTE: If other applications rely on having the OpenCL™, OpenGL®, and Vulkan® Compatibility Pack to work, then you may have issues with those applications.

If you are still encountering this issue after removing the Compatibility Pack or updating to Nuke 14.1v4 or 15.0v4, please submit a support ticket, referencing OpenCL in the ticket title, along with the following information:

1) Let us know that uninstalling the OpenCL™, OpenGL®, and Vulkan® Compatibility Pack didn't help, or that you did not have it installed in the first place.

 

2) Full system specifications of your machine.
Instructions for how to generate a report with this information can be found here:
Q100520: Obtaining operating system reports for hardware specs to send during Foundry Support investigations

 

3) As this issue may also be related to having both an integrated and dedicated GPU, we would suggest disabling your integrated GPU and rebooting your machine. Please let us know if this enables you to launch Nuke.
Information about how to disable your integrated GPU can be found here:
Q100578: Intel integrated graphics drivers causes Foundry software to crash on launch

 

4) Try a clean install of all GPU drivers on your machine, and let us know if this helps.
You can use Display Driver Uninstaller (DDU) to uninstall your GPU drivers, then download the latest GPU driver from your GPU manufacturer's website:

DDU:
https://www.guru3d.com/files-details/display-driver-uninstaller-download.html 


Nvidia Drivers:
https://www.nvidia.com/download/index.aspx 


AMD Drivers:
https://www.amd.com/en/support 

NOTE: As DDU is a third-party solution, we cannot provide any support for using it.

 

 
FURTHER READING 

For more information on how to open a Support ticket, please refer to our Q100064: How to raise a support ticket article.

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