SYMPTOMS
When trying to launch previous versions of Nuke with an Individual login-based license, you may see a License Expiry Warning message in the Licensing dialog:
Once the expiry is reached, Nuke will no longer be able to check out an Individual login-based license and will fail to launch.
CAUSE
A required server-side change to our licensing system affected communication between our products and the server which affects earlier product versions.
As a result, Individual license checkouts began failing when the local license token attempted to renew (every 37 days), despite valid licenses being available.
This issue affected login-based licenses on all operating systems and only Nuke versions released prior to May 20, 2025. Up-to-date Nuke versions should not be encountering this issue. All other Foundry products and license types were not impacted.
RESOLUTION
The latest versions of Nuke do not encounter this issue. If you are able to upgrade, we recommend downloading and installing one of these Nuke family product versions:
- 16.0v3 and above
- 15.2v3 and above
- 15.1v8 and above
- 15.0v8 and above
- 14.1v8 and above
You can download the latest Nuke family product versions here: https://downloads.foundry.com/nuke
WORKAROUND
If you are unable to upgrade to the latest versions of the Nuke family products at this time, you can work around via one of the following two methods.
Periodic manual license token renewal
To work around you will need to log out of the Individual login licensing system, delete the Tokens folder from your machine and log back in again.
NOTE: You'll need to repeat this every 37 days when your local license token renews.
A step by step guide on how to do this can be found here: Q100285: Initial steps to help solve issues with Individual Login-Based licensing
NOTE: The warning you are seeing is the expiry date for the specific license token on your machine. This does not reflect the expiry of your overall license entitlement.
Using an environment variable to point to a newer Nuke certificate bundle file
You can set the FN_CURLOPT_CAINFO environment variable to point to a newer Nuke certificate bundle file which will avoid the need for the periodic manual license token renewal steps above.
NOTE: You will need to remove any existing licensing tokens before setting this environment variable.
To implement this, please follow the guidance in this article: Q100720: How to work around login-based licensing issues without upgrading to the latest Nuke versions
FURTHER HELP
If you are still seeing any issues after performing the steps outlined in this article, then please open a Support ticket and let us know the issue you are encountering and the troubleshooting steps you have taken so far, including a screenshot of any error messages.
For more information on how to open a Support ticket, please refer to the Q100064: How to raise a support ticket article.
We're sorry to hear that
Please tell us why