Q100677: 'Port 4101 still in use, giving up' error when attempting to start the server

SYMPTOMS

When attempting to start your RLM server, instead of the server starting correctly and the licenses floating, the below errors appear:

==> 05/25 16:20 (rlm) Port 4101 in use, waiting...

==> 05/25 16:20 (rlm) Port 4101 in use, waiting...

==> 05/25 16:20 (rlm) Port 4101 in use, waiting...

==> 05/25 16:20 (rlm) Port 4101 still in use, giving up.
==> Error connecting to "rlm" server

==> Connection attempted to host: "<hostname>" on port 4101

==> Connection refused at server (-111)

==> Cannot connect to server (comm: -4)

 

CAUSE

4101 is the port specified on the HOST line of the license file, this is the port used by client machines to request licenses.  By default we issue our Foundry licenses with port 4101 on the HOST line to avoid conflicts with other RLM servers.

If you are seeing the error that the port is in use, this usually means that there is another RLM process on this machine floating from port 4101.

One reason this may happen is if the last Foundry RLM session running on your server did not exit cleanly. 

 

RESOLUTION
The first thing to ensure is that no other vendor on this server is using port 4101.

Once you are confident that there is nothing else using this port, please ensure that any old Foundry RLM processes on the machine are no longer running. You can completely stop the server from running by following these steps:

  1. Launch the Foundry Licensing Utility (FLU)
  2. Navigate to the 'License server' and 'Control' tab
  3. Stop the server if possible
  4. Navigate to the 'License server' and 'Uninstall' option and run the uninstaller
  5. Reinstall the server following installation steps: Q100360: How to install the server tools for Floating/server licenses
  6. Start the server

If you are using the FLU on a headless machine, please see the steps to stop and start the server here.

If you are not using the FLU, you can stop the server via rlmutil following these steps: 

 

  1. Open a command prompt or terminal
  2. Navigate to rlmutil via the following command

    Windows: cd C:\Program Files\The Foundry\LicensingTools8.0\bin\RLM
    Mac: cd /Applications/TheFoundry/LicensingTools8.0/bin/RLM/
    Linux: cd /usr/local/foundry/LicensingTools8.0/bin/RLM

  3. Use the rlmdown command to stop the server:
    E.g : rlmutil rlmdown foundry -c 4101@<hostname>

More information on this can be found here: Q100659: What is the rlmutil and how can I use it?

 

FURTHER READING 

If you are still experiencing difficulties please create a support ticket to let us know the exact issue encountered and the troubleshooting steps that have been taken.

For more information on how to open a support request, please refer to this article:

Q100064: How to raise a support ticket

More information on the rlmutil and its commands can be found in this documentation: Q100659: What is the rlmutil and how can I use it?

For more information on how to manage a license server, please see this article

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