SYMPTOMS
If you are having trouble starting up your Foundry server, you may come across the following error messages in the diagnostics log:
02/17 11:27 (rlm) foundry:0 initialization error: 8, not restarting
02/17 11:27 (rlm) foundry - lockfile problems
02/17 11:27 (rlm) This usually means another "foundry" server is running
CAUSE
When the Foundry ISV server starts up it writes the server lock file into the Reprise directory. This lock file is created as a reference / record that an RLM server is running for the Foundry (or any other additional isv vendor daemon).
The error message "initialization error: 8, not restarting" "foundry lock file problems" suggests that the server is experiencing issues creating the Foundry lock file in this directory. This is usually the case if another foundry ISV server is running on the same server machine at the same time.
This can occur if the ISV server does not exit cleanly and another instance of the Foundry server is still running on the server machine.
RESOLUTION
If you do encounter this issue on your license server, the best course of action would be to uninstall all Foundry RLM servers found on the server machine and reinstall the latest server tools.
To uninstall the server tools via FLU 8 and above, please run the following steps:
- Launch the Foundry Licensing Utility application
- Select License Server > Uninstall
- Follow the on-screen instructions to uninstall the server tools
If you have any old server tools installed from FLU 7, please use the following article to uninstall these tools: Q100135: How to uninstall old versions of Foundry Licensing Tools
When all server tools are uninstalled from the license server, reinstall the latest server tools by following the steps in this article: Q100360: How to install the server tools for Floating/server licenses
Make sure that you restart the server when installed. This will allow the licenses to float again.
FURTHER HELP
If you are still experiencing difficulties please create a support ticket to let us know the exact issue encountered and the troubleshooting steps that have been taken.
For more information on how to open a support request, please refer to this article:
Q100064: How to raise a support ticket
FURTHER READING
Our Support Portal provides further information and advice on using our Floating licenses. Specific guides related to this issue can be found below:
- Q100638: Initial troubleshooting steps for Floating License issues
- Q100360: How to install the server tools for Floating/server licenses
- Q100105: How to generate a License Diagnostic Log via the FLU for troubleshooting license issues
- Q100556: How to generate a diagnostic file from the RLM webserver
- Q100532: How to manage your license server using the Foundry Licensing Utility (FLU)
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